Installing TeXworks from PPA under (X)ubuntu

Due to the dependenciesmy Xubuntu wanted to install lots of packages from the Ubuntu TeX Live repository. I didn’t check explicitly but based on earlier experiences it’s safe to assume that it would be outdated. Besides that I had already installed TeX Live 2012. The solution was to check which packages Xubuntu wanted to install and to kick out everything not related with TeXworks.

The following worked smoothl (updated 2016-05-29)y:

  1. Open a terminal and enter: sudo add-apt-repository ppa:texworks/ppa, see https://launchpad.net/~texworks/+archive/ppa for details.
  2. Run the following command:
    sudo apt-get --no-install-recommends install fonts-lato fonts-lmodern javascript-common libjs-jquery libmng2 libmysqlclient20 libpoppler-qt4-4 libpotrace0 libptexenc1 libqt4-dbus libqt4-declarative libqt4-network libqt4-script libqt4-scripttools libqt4-sql libqt4-sql-mysql libqt4-xml libqt4-xmlpatterns libqtcore4 libqtdbus4 libqtgui4 libruby2.3 libsynctex1 libtexlua52 libtexluajit2 libzzip-0-13 lmodern mysql-common qdbus qt-at-spi qtchooser qtcore4-l10n rake ruby ruby-did-you-mean ruby-minitest ruby-net-telnet ruby-power-assert ruby-test-unit ruby2.3 rubygems-integration
    
  3. As of April 2018 the following works nicely:

    sudo apt-get --no-install-recommends install texworks fonts-lato javascript-common libjs-jquery libpoppler-qt5-1 libptexenc1 libqt5concurrent5 libqt5script5 libqt5scripttools5 libqt5xml5 libruby2.3 libsynctex1 libtexlua52 libtexluajit2 libzzip-0-13 rake ruby ruby-did-you-mean ruby-minitest ruby-net-telnet ruby-power-assert ruby-test-unit ruby2.3 rubygems-integration texworks-help-en texworks-scripting-lua texworks-scripting-python
    

Uwe

Uwe Ziegenhagen mag LaTeX und Python, auch gern in Kombination. Hat Dir dieser Beitrag geholfen und möchtest Du Dich dafür bedanken? Dann unterstütze doch vielleicht die Dingfabrik Köln e.V. mit einem kleinen Beitrag. Details zur Bezahlung findest Du unter Spenden für die Dingfabrik.

More Posts - Website